3 Commando Brigade

Realism. Tactics. Fun.

+ New Topic + Post Reply
7 posts in this topic
Posted: Thu May 10, 2018 11:57 pm     Super secret spam barrier
Quote
Offline

Posts: 66
Ribbons:
Service Medal (2) Zeus Operations (1) Mission Designer (1)
Public Regular (1) Operation Medal (2)

Mouse & Keyboard dead with new Motherboard?


So I've just installed my new Motherboard CPU and RAM into my pc and after the install I can only use a diffrent keyboard and my current mouse when using a PS/2 port emulator from my BIOS (Which makes the mouse run horribly btw)

Ive tried using Legacy USB Enabled and Disabled. Used diffrent mice and keyboards but as soon as it hits the OS (Windows 7) they switch off and refuse to work or even be detected.

Also I have checked my keyboard in 2 other machines and one says that it is not recognised and the other it works instantly. Mouse works on all other machines.

New Parts: Asus Prime Z370-p , I5 8600k, 16 GB 3000Mhz Dominator.

Thanks in advance if any of you can help because im fresh out of ideas.

- Andrew 


Posted: Fri May 11, 2018 4:49 pm     Super secret spam barrier
Quote
Offline
Colour Sergeant
Colour Sergeant
Other duties:
Site Admin
Server Admin

Posts: 400
Location: Germany
Ribbons:
Service Medal (4) Helpful Techie (1) Donator (1)
Public Regular (1) Operation Medal (3)
Ok,
cant figure it out quiet yet...
What is an ps/2 port emulator?! :D

Anyways things you can try:
- Boot Windows to Safe/Maintenance Mode, check if its working there
- Delete all HID drivers and rescan for devices (hardware manager)
- When you unplug and plug it back while Windows is booted, does anything happen?
- Download & install driver from your mouse & keybaord vendor


Posted: Fri May 11, 2018 5:17 pm     Super secret spam barrier
Quote
Offline

Posts: 5913
Location: Essen, Germany
Ribbons:
Service Medal (5) Media Man (2) Donator (1)
Training Team (1) Frag of the match (1) Zeus Operations (1)
Mission Designer (1) Leadership (1) Asset Medal [Armour] (1)
Public Regular (1) Operation Medal (3) Weapons Operator (1)
PS2 is a old connection.

Image

There is no war to end all wars.


Posted: Fri May 11, 2018 5:33 pm     Super secret spam barrier
Quote
Offline
Colour Sergeant
Colour Sergeant
Other duties:
Site Admin
Server Admin

Posts: 400
Location: Germany
Ribbons:
Service Medal (4) Helpful Techie (1) Donator (1)
Public Regular (1) Operation Medal (3)
Mefirst wrote:
PS2 is a old connection.

the emulator part is what is confusing me :D

Image
usb < ps/2 !!!


Posted: Fri May 11, 2018 5:57 pm     Super secret spam barrier
Quote
Offline
Recruit
Recruit
Other duties:

Posts: 158
A driver issue with windows 7 possibly?

Sent from my SM-A320FL using Tapatalk


Posted: Sun May 20, 2018 9:10 pm     Super secret spam barrier
Quote
Offline

Posts: 196
Location: Netherlands
Ribbons:
Service Medal (2) Mission Designer (1) Public Regular (1)
Operation Medal (3)
So apparently USB port to PS/2 emulator works as the following.

In this connection we have some problems with the automatic emulation of USB keyboard and mouse to PS/2 performed in the BIOS. Basically the BIOS emulates PS/2 keyboard and mouse devices for operating systems that wish to use this instead of USB keyboard and mouse. It does this (as far as I understand) by inserting itself in all PCI USB hubs found on the system. In order to ensure the OS does not interfere with this emulation, the used resources are reported via ACPI RMRR records. Lenovo forums

Although this still is no answer to your issue, try what reV said and additionally check your motherboard drivers + update BIOS if update has been released.


Additionally if I remember correctly you had a Gigabyte motherboard. Try the following if applicable.
Turn on/off a Lock on the USB keyboard, the PS/2 keyboard's Lock state also changes. The PS/2 keyboard is seen in Win10's device manager, drivers are reportedly up-to-date. Additionally, if I unplug/re-plug the PS/2 keyboard, it starts working (required after every reboot) Superuser forums


Posted: Mon May 21, 2018 7:03 am     Super secret spam barrier
Quote
Offline

Posts: 66
Ribbons:
Service Medal (2) Zeus Operations (1) Mission Designer (1)
Public Regular (1) Operation Medal (2)
Delayed Update: Decided to have a fresh install of everything and updated (Reluctantly :/) to Windows 10 and still didn't work so just bought a new keyboard (Razer Blackwidow Croma V2) and everything is working fine now.

Didn't see the recommendations in time but huge thanks guys for the assistance anyways guys :D 

TLRD: 7 year old keyboard finally died, Replaced it and fixed problems 


+ New Topic + Post Reply


Who is online

Users browsing this forum: No registered users and 4 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

phpBB © Forum Software
© 3 Commando Brigade Gaming Community
All images belong to their respective owners


3CB Modern design by Jamie Goodson
WysiBB